GMP: require just i686, not pentium4
authorRudolf Polzer <divVerent@alientrap.org>
Tue, 14 Sep 2010 13:32:48 +0000 (15:32 +0200)
committerRudolf Polzer <divVerent@alientrap.org>
Tue, 14 Sep 2010 13:32:48 +0000 (15:32 +0200)
misc/builddeps/dp.linux32/include/gmp.h
misc/builddeps/dp.linux32/lib/libgmp.a
misc/builddeps/dp.linux32/lib/libgmp.la

index ee5647e..7b531f5 100644 (file)
@@ -2268,7 +2268,7 @@ enum
 
 /* Define CC and CFLAGS which were used to build this version of GMP */
 #define __GMP_CC "gcc -std=gnu99"
-#define __GMP_CFLAGS "-m32 -O2 -pedantic -fomit-frame-pointer -mtune=pentium4 -march=pentium4"
+#define __GMP_CFLAGS "-m32 -O2 -pedantic -fomit-frame-pointer -mtune=pentiumpro -march=pentiumpro"
 
 /* Major version number is the value of __GNU_MP__ too, above and in mp.h. */
 #define __GNU_MP_VERSION 5
index 555b7bf..e61da30 100644 (file)
Binary files a/misc/builddeps/dp.linux32/lib/libgmp.a and b/misc/builddeps/dp.linux32/lib/libgmp.a differ
index 34fab8f..b612477 100755 (executable)
@@ -38,4 +38,4 @@ dlopen=''
 dlpreopen=''
 
 # Directory that this library needs to be installed in:
-libdir='/tmp/g/lib'
+libdir='/tmp/gg/lib'