]> git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/archlinux/git/PKGBUILD
4687a74446971990cbc3c523320ca4f64fca47b0
[xonotic/gmqcc.git] / distro / archlinux / git / PKGBUILD
1 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
2
3 pkgname=gmqcc-git
4 pkgver=0.2.524.gc6bd5e6
5 pkgver(){
6     cd gmqcc
7     git describe --tags | sed -e 's/^gmqcc\-//' -e 's/-/./g'
8 }
9 pkgrel=1
10 pkgdesc="An Improved Quake C Compiler"
11 arch=('i686' 'x86_64')
12 depends=('glibc')
13 conflicts=('gmqcc')
14 provides=('gmqcc=0.2.4')v
15 makedepends=('git')
16 url="https://github.com/graphitemaster/gmqcc.git"
17 license=('MIT')
18 source=('gmqcc::git://github.com/graphitemaster/gmqcc.git')
19 sha1sums=('SKIP')
20
21
22 build() {
23         cd $srcdir
24
25         msg "Starting compilation..."
26         cd "$srcdir"/"gmqcc"
27
28         msg "Compiling..."
29         make
30 }
31
32 check() {
33         cd "$srcdir"/"gmqcc"
34         make check
35 }
36
37 package() {
38         cd "$srcdir"/"gmqcc"
39         msg "Compiling and installing to pkgdir this time..."
40         make install DESTDIR=$pkgdir PREFIX=/usr
41         msg "Compiling done."
42
43         install -D LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
44 }