]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archlinux/release/PKGBUILD
regular procedure... bumping PKGBUILDs, GMQCC_VERSION macros, adding back GMQCC_VERSI...
[xonotic/gmqcc.git] / distro / archlinux / release / PKGBUILD
index ef7de8fea3c2b8a06e5b9ac5dddfaeba7b592ed6..980ca5510df2dc785b18f54aefa70c6e29a787fe 100644 (file)
@@ -1,7 +1,8 @@
 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
+# Contributor: Wolfgang Bumiller <blub@speed.at>
 
 pkgname=gmqcc
-pkgver=0.2.2
+pkgver=0.3.5
 pkgrel=1
 pkgdesc="An Improved Quake C Compiler"
 arch=('i686' 'x86_64')
@@ -9,9 +10,9 @@ depends=('glibc')
 url="https://github.com/graphitemaster/gmqcc.git"
 license=('MIT')
 source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver)
-sha1sums=('e0fe99af9a55d36cd9e0909a96d1b14f2db8b757')
+sha1sums=('69085478f48f04eefbd2a088c1bd8c266b59f952')
 
-_gitname=graphitemaster-gmqcc-de24486/
+_gitname=graphitemaster-gmqcc-7f2b206/
 
 build() {
        msg "Starting compilation..."
@@ -32,5 +33,6 @@ package() {
        make install DESTDIR=$pkgdir PREFIX=/usr
        msg "Compiling done."
 
-       install -D LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
+       install -dm755 ${pkgdir}/usr/share/licenses/gmqcc
+       install -m644 LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
 }