]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archlinux/release/PKGBUILD
PKGBUILD: archlinux: fix build by applying a patch (4c4aa5534c34) on 0.2.9 package.
[xonotic/gmqcc.git] / distro / archlinux / release / PKGBUILD
index c46d83b022bad7ced2759308d4f31588c7833842..2c933bf8851a175de7176729f7bfb9927a02f3b9 100644 (file)
@@ -9,11 +9,19 @@ arch=('i686' 'x86_64')
 depends=('glibc')
 url="https://github.com/graphitemaster/gmqcc.git"
 license=('MIT')
-source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver)
-sha1sums=('adf972360c0b3d2f032a688952f6fb4715e4d45b')
+source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver
+           build_fix.patch) # commit 4c4aa5534c34
+
+sha1sums=('adf972360c0b3d2f032a688952f6fb4715e4d45b'
+                '0b69dc8b786c7617fe17e6a5fd70407d1c4153d6')
 
 _gitname=graphitemaster-gmqcc-219508e/
 
+prepare() {
+       cd "$srcdir"/"$_gitname"
+       patch -p1 <../build_fix.patch
+}
+
 build() {
        msg "Starting compilation..."
        cd "$srcdir"/"$_gitname"