]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archlinux/git/PKGBUILD
Merge pull request #104 from matthiaskrgr/PKGBUILD_master
[xonotic/gmqcc.git] / distro / archlinux / git / PKGBUILD
index 4a9127cf37d532173b54cb2a13035c9570c19812..ac00fefcfcf9475539540c90cf2d216418e9728b 100644 (file)
@@ -1,7 +1,11 @@
 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
 
 pkgname=gmqcc-git
-pkgver=20130127
+pkgver=0.2.612.g160e7cf
+pkgver(){
+    cd gmqcc
+    git describe --tags | sed -e 's/^gmqcc\-//' -e 's/-/./g'
+}
 pkgrel=1
 pkgdesc="An Improved Quake C Compiler"
 arch=('i686' 'x86_64')
@@ -11,43 +15,34 @@ provides=('gmqcc=0.2.4')
 makedepends=('git')
 url="https://github.com/graphitemaster/gmqcc.git"
 license=('MIT')
+source=('gmqcc::git://github.com/graphitemaster/gmqcc.git')
+sha1sums=('SKIP')
 
-_gitroot="git://github.com/graphitemaster/gmqcc.git"
-_gitname="gmqcc"
 
 build() {
-       cd $srcdir
-       msg "Connecting to the GIT server..."
-       if [[ -d $srcdir/$_gitname ]] ; then
-               cd $_gitname
-               msg "Removing build files..."
-               git clean -dfx
-               msg "Updating..."
-               git pull --no-tags
-               msg "The local files are updated."
-       else
-               msg "Cloning..."
-               git clone $_gitroot $_gitname --depth 1
-               msg "Clone done."
-       fi
-
        msg "Starting compilation..."
-       cd "$srcdir"/"$_gitname"
+       cd "$srcdir"/"gmqcc"
 
        msg "Compiling..."
        make
 }
 
 check() {
-       cd "$srcdir"/"$_gitname"
+       cd "$srcdir"/"gmqcc"
        make check
 }
 
 package() {
-       cd "$srcdir"/"$_gitname"
+       cd "$srcdir"/"gmqcc"
        msg "Compiling and installing to pkgdir this time..."
        make install DESTDIR=$pkgdir PREFIX=/usr
        msg "Compiling done."
 
-       install -D LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
+       install -Dm644 syntax/geany/filetypes.qc    ${pkgdir}/usr/share/geany/filetypes.qc
+       install -Dm644 syntax/gtksourceview/qc.lang ${pkgdir}/usr/share/gtksourceview-3.0/language-specs/qc.lang
+       # jedit
+       install -Dm644 syntax/kate/qc.xml ${pkgdir}/usr/share/apps/katepart/syntax/qc.xml
+       install -Dm644 syntax/nano/qc.nanorc ${pkgdir}/usr/share/nano/qc.nanorc
+
+       install -Dm644 LICENSE                                   ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
 }