]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archbsd/release/PKGBUILD
PKGBUILDs: rename "arch" to "archlinux", move archbsd PKGBUILDs into own "archbsd...
[xonotic/gmqcc.git] / distro / archbsd / release / PKGBUILD
diff --git a/distro/archbsd/release/PKGBUILD b/distro/archbsd/release/PKGBUILD
new file mode 100644 (file)
index 0000000..8c449c6
--- /dev/null
@@ -0,0 +1,38 @@
+# Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
+# Contributor: Wolfgang Bumiller <blub@speed.at>
+
+pkgname=gmqcc
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="An Improved Quake C Compiler"
+arch=('i686' 'x86_64')
+depends=()
+url="https://github.com/graphitemaster/gmqcc.git"
+license=('MIT')
+source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver)
+sha1sums=('8cd91dc13f70cd9d3767602bf3eb47a1906d9353')
+
+_gitname=graphitemaster-gmqcc-de24486/
+
+build() {
+       msg "Starting compilation..."
+       cd "$srcdir"/"$_gitname"
+
+       msg "Compiling..."
+       gmake
+}
+
+check() {
+       cd "$srcdir"/"$_gitname"
+       gmake check
+}
+
+package() {
+       cd "$srcdir"/"$_gitname"
+       msg "Compiling and installing to pkgdir this time..."
+       gmake install DESTDIR=$pkgdir PREFIX=/usr/local MANDIR=/usr/local/man
+       msg "Compiling done."
+
+       install -dm755 ${pkgdir}/usr/local/share/licenses/gmqcc
+       install -m644 LICENSE ${pkgdir}/usr/local/share/licenses/gmqcc/LICENSE
+}