]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archbsd/release/PKGBUILD
Remove all the support stuff
[xonotic/gmqcc.git] / distro / archbsd / release / PKGBUILD
diff --git a/distro/archbsd/release/PKGBUILD b/distro/archbsd/release/PKGBUILD
deleted file mode 100644 (file)
index a57846c..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
-# Contributor: Wolfgang Bumiller <blub@speed.at>
-
-pkgname=gmqcc
-pkgver=0.3.5
-pkgrel=1
-pkgdesc="An Improved Quake C Compiler"
-arch=('i686' 'x86_64')
-depends=()
-url="https://github.com/graphitemaster/gmqcc.git"
-license=('MIT')
-source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver)
-sha1sums=('69085478f48f04eefbd2a088c1bd8c266b59f952')
-
-_gitname=graphitemaster-gmqcc-7f2b206/
-
-build() {
-       msg "Starting compilation..."
-       cd "$srcdir"/"$_gitname"
-
-       msg "Compiling..."
-       gmake
-}
-
-check() {
-       cd "$srcdir"/"$_gitname"
-       gmake check
-}
-
-package() {
-       cd "$srcdir"/"$_gitname"
-       msg "Compiling and installing to pkgdir this time..."
-       gmake install DESTDIR=$pkgdir PREFIX=/usr
-       msg "Compiling done."
-
-       install -dm755 ${pkgdir}/usr/share/licenses/gmqcc
-       install -m644 LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
-}