]> git.xonotic.org Git - xonotic/gmqcc.git/blobdiff - distro/archbsd/git/PKGBUILD
Remove all the support stuff
[xonotic/gmqcc.git] / distro / archbsd / git / PKGBUILD
diff --git a/distro/archbsd/git/PKGBUILD b/distro/archbsd/git/PKGBUILD
deleted file mode 100644 (file)
index f1ec819..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
-# Contributor: Wolfgang Bumiller <blub@speed.at>
-
-pkgname=gmqcc-git
-pkgver=20131031
-pkgrel=1
-pkgdesc="An Improved Quake C Compiler"
-arch=('i686' 'x86_64')
-depends=()
-conflicts=('gmqcc')
-provides=('gmqcc=0.3.5')
-makedepends=('git')
-url="https://github.com/graphitemaster/gmqcc.git"
-license=('MIT')
-
-_gitroot="git://github.com/graphitemaster/gmqcc.git"
-_gitname="gmqcc"
-
-build() {
-       cd $srcdir
-       msg "Connecting to the GIT server..."
-       if [[ -d $srcdir/$_gitname ]] ; then
-               cd $_gitname
-               msg "Removing build files..."
-               git clean -dfx
-               msg "Updating..."
-               git pull --no-tags
-               msg "The local files are updated."
-       else
-               msg "Cloning..."
-               git clone $_gitroot $_gitname --depth 1
-               msg "Clone done."
-       fi
-
-       msg "Starting compilation..."
-       cd "$srcdir"/"$_gitname"
-
-       msg "Compiling..."
-       gmake
-}
-
-check() {
-       cd "$srcdir"/"$_gitname"
-       gmake check
-}
-
-package() {
-       cd "$srcdir"/"$_gitname"
-       msg "Compiling and installing to pkgdir this time..."
-       gmake install DESTDIR=$pkgdir PREFIX=/usr
-       msg "Compiling done."
-
-       install -dm755 ${pkgdir}/usr/share/licenses/gmqcc
-       install -m644 LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
-}