]> git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/fedora/gmqcc.spec
add updated spec and rename it
[xonotic/gmqcc.git] / distro / fedora / gmqcc.spec
1 Name:           gmqcc
2 Version:        0.2.9
3 Release:        1%{?dist}
4 Summary:        Improved Quake C Compiler
5 License:        MIT
6 URL:            http://graphitemaster.github.io/gmqcc/
7 Source0:        https://github.com/graphitemaster/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
8 # Downstream patch. TODO: drop it in 0.3.0 release.
9 Patch0:         build_fix.patch
10
11 %description
12 Modern written-from-scratch compiler for the QuakeC language with
13 support for many common features found in other QC compilers.
14
15 %package -n qcvm
16 Summary:        Standalone QuakeC VM binary executor
17
18 %description -n qcvm
19 Executor for QuakeC VM binary files created using a QC compiler such
20 as gmqcc or fteqcc. It provides a small set of built-in functions, and
21 by default executes the main function if there is one. Some options
22 useful for debugging are available as well.
23
24 # TODO: add new package gmqpak after 0.3.0 release
25
26 %prep
27 %setup -q
28 %patch0 -p1
29 echo '#!/bin/sh' > ./configure
30 chmod +x ./configure 
31
32 %build
33 %configure
34 make %{?_smp_mflags}
35
36 %install
37 %make_install PREFIX=%{_prefix}
38
39 %check
40 make check
41
42 %files
43 %doc LICENSE README AUTHORS CHANGES TODO
44 %doc gmqcc.ini.example
45 %doc %{_mandir}/man1/gmqcc.1.gz
46 %{_bindir}/gmqcc
47
48 %files -n qcvm
49 %doc LICENSE README AUTHORS CHANGES TODO
50 %doc %{_mandir}/man1/qcvm.1.gz
51 %{_bindir}/qcvm
52
53 %changelog
54 * Sat Jul 27 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.2.9-1
55 - Initial release