]> git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/archlinux/release/PKGBUILD
PKGBUILD: archlinux: fix build by applying a patch (4c4aa5534c34) on 0.2.9 package.
[xonotic/gmqcc.git] / distro / archlinux / release / PKGBUILD
1 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
2 # Contributor: Wolfgang Bumiller <blub@speed.at>
3
4 pkgname=gmqcc
5 pkgver=0.2.9
6 pkgrel=1
7 pkgdesc="An Improved Quake C Compiler"
8 arch=('i686' 'x86_64')
9 depends=('glibc')
10 url="https://github.com/graphitemaster/gmqcc.git"
11 license=('MIT')
12 source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver
13             build_fix.patch) # commit 4c4aa5534c34
14
15 sha1sums=('adf972360c0b3d2f032a688952f6fb4715e4d45b'
16                  '0b69dc8b786c7617fe17e6a5fd70407d1c4153d6')
17
18 _gitname=graphitemaster-gmqcc-219508e/
19
20 prepare() {
21         cd "$srcdir"/"$_gitname"
22         patch -p1 <../build_fix.patch
23 }
24
25 build() {
26         msg "Starting compilation..."
27         cd "$srcdir"/"$_gitname"
28
29         msg "Compiling..."
30         make
31 }
32
33 check() {
34         cd "$srcdir"/"$_gitname"
35         make check
36 }
37
38 package() {
39         cd "$srcdir"/"$_gitname"
40         msg "Compiling and installing to pkgdir this time..."
41         make install DESTDIR=$pkgdir PREFIX=/usr
42         msg "Compiling done."
43
44         install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
45 }