]> git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/archlinux/git/PKGBUILD
PKGBUILD: archlinux: git: install syntax files to respective dirs.
[xonotic/gmqcc.git] / distro / archlinux / git / PKGBUILD
1 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
2
3 pkgname=gmqcc-git
4 pkgver=0.2.612.g160e7cf
5 pkgver(){
6     cd gmqcc
7     git describe --tags | sed -e 's/^gmqcc\-//' -e 's/-/./g'
8 }
9 pkgrel=1
10 pkgdesc="An Improved Quake C Compiler"
11 arch=('i686' 'x86_64')
12 depends=('glibc')
13 conflicts=('gmqcc')
14 provides=('gmqcc=0.2.4')
15 makedepends=('git')
16 url="https://github.com/graphitemaster/gmqcc.git"
17 license=('MIT')
18 source=('gmqcc::git://github.com/graphitemaster/gmqcc.git')
19 sha1sums=('SKIP')
20
21
22 build() {
23         msg "Starting compilation..."
24         cd "$srcdir"/"gmqcc"
25
26         msg "Compiling..."
27         make
28 }
29
30 check() {
31         cd "$srcdir"/"gmqcc"
32         make check
33 }
34
35 package() {
36         cd "$srcdir"/"gmqcc"
37         msg "Compiling and installing to pkgdir this time..."
38         make install DESTDIR=$pkgdir PREFIX=/usr
39         msg "Compiling done."
40
41         install -Dm644 syntax/geany/filetypes.qc    ${pkgdir}/usr/share/geany/filetypes.qc
42         install -Dm644 syntax/gtksourceview/qc.lang ${pkgdir}/usr/share/gtksourceview-3.0/language-specs/qc.lang
43         # jedit
44         install -Dm644 syntax/kate/qc.xml ${pkgdir}/usr/share/apps/katepart/syntax/qc.xml
45         install -Dm644 syntax/nano/qc.nanorc ${pkgdir}/usr/share/nano/qc.nanorc
46
47         install -Dm644 LICENSE                                   ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
48 }