]> git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/archbsd/release/PKGBUILD
PKGBUILDs: rename "arch" to "archlinux", move archbsd PKGBUILDs into own "archbsd...
[xonotic/gmqcc.git] / distro / archbsd / release / PKGBUILD
1 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
2 # Contributor: Wolfgang Bumiller <blub@speed.at>
3
4 pkgname=gmqcc
5 pkgver=0.2.2
6 pkgrel=1
7 pkgdesc="An Improved Quake C Compiler"
8 arch=('i686' 'x86_64')
9 depends=()
10 url="https://github.com/graphitemaster/gmqcc.git"
11 license=('MIT')
12 source=(gmqcc-$pkgver.zip::https://github.com/graphitemaster/gmqcc/zipball/$pkgver)
13 sha1sums=('8cd91dc13f70cd9d3767602bf3eb47a1906d9353')
14
15 _gitname=graphitemaster-gmqcc-de24486/
16
17 build() {
18         msg "Starting compilation..."
19         cd "$srcdir"/"$_gitname"
20
21         msg "Compiling..."
22         gmake
23 }
24
25 check() {
26         cd "$srcdir"/"$_gitname"
27         gmake check
28 }
29
30 package() {
31         cd "$srcdir"/"$_gitname"
32         msg "Compiling and installing to pkgdir this time..."
33         gmake install DESTDIR=$pkgdir PREFIX=/usr/local MANDIR=/usr/local/man
34         msg "Compiling done."
35
36         install -dm755 ${pkgdir}/usr/local/share/licenses/gmqcc
37         install -m644 LICENSE ${pkgdir}/usr/local/share/licenses/gmqcc/LICENSE
38 }