]> git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/CMakeLists.txt
Build quake2 tools
[xonotic/netradiant.git] / tools / CMakeLists.txt
index 81216495f2c802c84e6b003e7dd58ef7bddaff65..52c5f18cab8aa5e8cba971591d9758c6ad30b547 100644 (file)
@@ -3,234 +3,4 @@
 set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}")
 
 add_subdirectory(quake3)
-
-set(QUAKE2LIST
-    tools/quake2/common/bspfile.c
-    tools/quake2/common/bspfile.h
-    tools/quake2/common/cmdlib.c
-    tools/quake2/common/cmdlib.h
-    tools/quake2/common/inout.c
-    tools/quake2/common/inout.h
-    tools/quake2/common/l3dslib.c
-    tools/quake2/common/l3dslib.h
-    tools/quake2/common/lbmlib.c
-    tools/quake2/common/lbmlib.h
-    tools/quake2/common/mathlib.c
-    tools/quake2/common/mathlib.h
-    tools/quake2/common/md4.c
-    tools/quake2/common/md4.h
-    tools/quake2/common/path_init.c
-    tools/quake2/common/polylib.c
-    tools/quake2/common/polylib.h
-    tools/quake2/common/q2_threads.h
-    tools/quake2/common/qfiles.h
-    tools/quake2/common/scriplib.c
-    tools/quake2/common/scriplib.h
-    tools/quake2/common/threads.c
-    tools/quake2/common/trilib.c
-    tools/quake2/common/trilib.h
-    tools/quake2/extra/bsp/bspinfo3/bspinfo3.c
-    tools/quake2/extra/bsp/qbsp3/brushbsp.c
-    tools/quake2/extra/bsp/qbsp3/csg.c
-    tools/quake2/extra/bsp/qbsp3/faces.c
-    tools/quake2/extra/bsp/qbsp3/gldraw.c
-    tools/quake2/extra/bsp/qbsp3/glfile.c
-    tools/quake2/extra/bsp/qbsp3/leakfile.c
-    tools/quake2/extra/bsp/qbsp3/map.c
-    tools/quake2/extra/bsp/qbsp3/nodraw.c
-    tools/quake2/extra/bsp/qbsp3/portals.c
-    tools/quake2/extra/bsp/qbsp3/prtfile.c
-    tools/quake2/extra/bsp/qbsp3/qbsp.h
-    tools/quake2/extra/bsp/qbsp3/qbsp3.c
-    tools/quake2/extra/bsp/qbsp3/textures.c
-    tools/quake2/extra/bsp/qbsp3/tree.c
-    tools/quake2/extra/bsp/qbsp3/writebsp.c
-    tools/quake2/extra/bsp/qrad3/lightmap.c
-    tools/quake2/extra/bsp/qrad3/patches.c
-    tools/quake2/extra/bsp/qrad3/qrad.h
-    tools/quake2/extra/bsp/qrad3/qrad3.c
-    tools/quake2/extra/bsp/qrad3/trace.c
-    tools/quake2/extra/bsp/qvis3/flow.c
-    tools/quake2/extra/bsp/qvis3/qvis3.c
-    tools/quake2/extra/bsp/qvis3/vis.h
-    tools/quake2/extra/common/bspfile.c
-    tools/quake2/extra/common/bspfile.h
-    tools/quake2/extra/common/cmdlib.c
-    tools/quake2/extra/common/cmdlib.h
-    tools/quake2/extra/common/l3dslib.c
-    tools/quake2/extra/common/l3dslib.h
-    tools/quake2/extra/common/lbmlib.c
-    tools/quake2/extra/common/lbmlib.h
-    tools/quake2/extra/common/mathlib.c
-    tools/quake2/extra/common/mathlib.h
-    tools/quake2/extra/common/mdfour.c
-    tools/quake2/extra/common/mdfour.h
-    tools/quake2/extra/common/polylib.c
-    tools/quake2/extra/common/polylib.h
-    tools/quake2/extra/common/qfiles.h
-    tools/quake2/extra/common/scriplib.c
-    tools/quake2/extra/common/scriplib.h
-    tools/quake2/extra/common/threads.c
-    tools/quake2/extra/common/threads.h
-    tools/quake2/extra/common/trilib.c
-    tools/quake2/extra/common/trilib.h
-    tools/quake2/extra/qdata/anorms.h
-    tools/quake2/extra/qdata/images.c
-    tools/quake2/extra/qdata/models.c
-    tools/quake2/extra/qdata/qdata.c
-    tools/quake2/extra/qdata/qdata.h
-    tools/quake2/extra/qdata/sprites.c
-    tools/quake2/extra/qdata/tables.c
-    tools/quake2/extra/qdata/video.c
-    tools/quake2/extra/qe4/brush.c
-    tools/quake2/extra/qe4/brush.h
-    tools/quake2/extra/qe4/bspfile.h
-    tools/quake2/extra/qe4/camera.c
-    tools/quake2/extra/qe4/camera.h
-    tools/quake2/extra/qe4/cmdlib.c
-    tools/quake2/extra/qe4/cmdlib.h
-    tools/quake2/extra/qe4/csg.c
-    tools/quake2/extra/qe4/drag.c
-    tools/quake2/extra/qe4/eclass.c
-    tools/quake2/extra/qe4/entity.c
-    tools/quake2/extra/qe4/entity.h
-    tools/quake2/extra/qe4/entityw.h
-    tools/quake2/extra/qe4/glingr.h
-    tools/quake2/extra/qe4/lbmlib.c
-    tools/quake2/extra/qe4/lbmlib.h
-    tools/quake2/extra/qe4/map.c
-    tools/quake2/extra/qe4/map.h
-    tools/quake2/extra/qe4/mathlib.c
-    tools/quake2/extra/qe4/mathlib.h
-    tools/quake2/extra/qe4/mru.c
-    tools/quake2/extra/qe4/mru.h
-    tools/quake2/extra/qe4/parse.c
-    tools/quake2/extra/qe4/parse.h
-    tools/quake2/extra/qe4/points.c
-    tools/quake2/extra/qe4/qe3.c
-    tools/quake2/extra/qe4/qe3.h
-    tools/quake2/extra/qe4/qedefs.h
-    tools/quake2/extra/qe4/qfiles.h
-    tools/quake2/extra/qe4/resource.h
-    tools/quake2/extra/qe4/select.c
-    tools/quake2/extra/qe4/select.h
-    tools/quake2/extra/qe4/textures.c
-    tools/quake2/extra/qe4/textures.h
-    tools/quake2/extra/qe4/vertsel.c
-    tools/quake2/extra/qe4/view.h
-    tools/quake2/extra/qe4/win_cam.c
-    tools/quake2/extra/qe4/win_dlg.c
-    tools/quake2/extra/qe4/win_ent.c
-    tools/quake2/extra/qe4/win_main.c
-    tools/quake2/extra/qe4/win_qe3.c
-    tools/quake2/extra/qe4/win_xy.c
-    tools/quake2/extra/qe4/win_z.c
-    tools/quake2/extra/qe4/xy.c
-    tools/quake2/extra/qe4/xy.h
-    tools/quake2/extra/qe4/z.c
-    tools/quake2/extra/qe4/z.h
-    tools/quake2/extra/texpaint/resource.h
-    tools/quake2/extra/texpaint/texpaint.c
-    tools/quake2/extra/texpaint/texpaint.h
-    tools/quake2/extra/texpaint/win_cam.c
-    tools/quake2/extra/texpaint/win_main.c
-    tools/quake2/extra/texpaint/win_pal.c
-    tools/quake2/extra/texpaint/win_skin.c
-    tools/quake2/q2map/brushbsp.c
-    tools/quake2/q2map/csg.c
-    tools/quake2/q2map/faces.c
-    tools/quake2/q2map/flow.c
-    tools/quake2/q2map/gldraw.c
-    tools/quake2/q2map/glfile.c
-    tools/quake2/q2map/leakfile.c
-    tools/quake2/q2map/lightmap.c
-    tools/quake2/q2map/main.c
-    tools/quake2/q2map/map.c
-    tools/quake2/q2map/nodraw.c
-    tools/quake2/q2map/patches.c
-    tools/quake2/q2map/portals.c
-    tools/quake2/q2map/prtfile.c
-    tools/quake2/q2map/q2map.h
-    tools/quake2/q2map/qbsp.c
-    tools/quake2/q2map/qbsp.h
-    tools/quake2/q2map/qrad.c
-    tools/quake2/q2map/qrad.h
-    tools/quake2/q2map/qvis.c
-    tools/quake2/q2map/qvis.h
-    tools/quake2/q2map/textures.c
-    tools/quake2/q2map/trace.c
-    tools/quake2/q2map/tree.c
-    tools/quake2/q2map/writebsp.c
-    tools/quake2/qdata/anorms.h
-    tools/quake2/qdata/images.c
-    tools/quake2/qdata/models.c
-    tools/quake2/qdata/qdata.c
-    tools/quake2/qdata/qdata.h
-    tools/quake2/qdata/sprites.c
-    tools/quake2/qdata/tables.c
-    tools/quake2/qdata/video.c
-    tools/quake2/qdata_heretic2/common/bspfile.c
-    tools/quake2/qdata_heretic2/common/bspfile.h
-    tools/quake2/qdata_heretic2/common/cmdlib.c
-    tools/quake2/qdata_heretic2/common/cmdlib.h
-    tools/quake2/qdata_heretic2/common/her2_threads.h
-    tools/quake2/qdata_heretic2/common/inout.c
-    tools/quake2/qdata_heretic2/common/inout.h
-    tools/quake2/qdata_heretic2/common/l3dslib.c
-    tools/quake2/qdata_heretic2/common/l3dslib.h
-    tools/quake2/qdata_heretic2/common/lbmlib.c
-    tools/quake2/qdata_heretic2/common/lbmlib.h
-    tools/quake2/qdata_heretic2/common/mathlib.c
-    tools/quake2/qdata_heretic2/common/mathlib.h
-    tools/quake2/qdata_heretic2/common/md4.c
-    tools/quake2/qdata_heretic2/common/md4.h
-    tools/quake2/qdata_heretic2/common/path_init.c
-    tools/quake2/qdata_heretic2/common/polylib.c
-    tools/quake2/qdata_heretic2/common/polylib.h
-    tools/quake2/qdata_heretic2/common/qfiles.c
-    tools/quake2/qdata_heretic2/common/qfiles.h
-    tools/quake2/qdata_heretic2/common/scriplib.c
-    tools/quake2/qdata_heretic2/common/scriplib.h
-    tools/quake2/qdata_heretic2/common/threads.c
-    tools/quake2/qdata_heretic2/common/token.c
-    tools/quake2/qdata_heretic2/common/token.h
-    tools/quake2/qdata_heretic2/common/trilib.c
-    tools/quake2/qdata_heretic2/common/trilib.h
-    tools/quake2/qdata_heretic2/qcommon/angles.h
-    tools/quake2/qdata_heretic2/qcommon/arrayedlist.h
-    tools/quake2/qdata_heretic2/qcommon/flex.h
-    tools/quake2/qdata_heretic2/qcommon/fmodel.h
-    tools/quake2/qdata_heretic2/qcommon/h2common.h
-    tools/quake2/qdata_heretic2/qcommon/placement.h
-    tools/quake2/qdata_heretic2/qcommon/q_typedef.h
-    tools/quake2/qdata_heretic2/qcommon/qfiles.h
-    tools/quake2/qdata_heretic2/qcommon/reference.c
-    tools/quake2/qdata_heretic2/qcommon/reference.h
-    tools/quake2/qdata_heretic2/qcommon/resourcemanager.c
-    tools/quake2/qdata_heretic2/qcommon/resourcemanager.h
-    tools/quake2/qdata_heretic2/qcommon/skeletons.c
-    tools/quake2/qdata_heretic2/qcommon/skeletons.h
-    tools/quake2/qdata_heretic2/adpcm.h
-    tools/quake2/qdata_heretic2/animcomp.c
-    tools/quake2/qdata_heretic2/animcomp.h
-    tools/quake2/qdata_heretic2/anorms.h
-    tools/quake2/qdata_heretic2/book.c
-    tools/quake2/qdata_heretic2/fmodels.c
-    tools/quake2/qdata_heretic2/images.c
-    tools/quake2/qdata_heretic2/jointed.c
-    tools/quake2/qdata_heretic2/jointed.h
-    tools/quake2/qdata_heretic2/joints.h
-    tools/quake2/qdata_heretic2/models.c
-    tools/quake2/qdata_heretic2/pics.c
-    tools/quake2/qdata_heretic2/qd_fmodel.h
-    tools/quake2/qdata_heretic2/qd_skeletons.c
-    tools/quake2/qdata_heretic2/qd_skeletons.h
-    tools/quake2/qdata_heretic2/qdata.c
-    tools/quake2/qdata_heretic2/qdata.h
-    tools/quake2/qdata_heretic2/resource.h
-    tools/quake2/qdata_heretic2/sprites.c
-    tools/quake2/qdata_heretic2/svdcmp.c
-    tools/quake2/qdata_heretic2/tables.c
-    tools/quake2/qdata_heretic2/tmix.c
-    tools/quake2/qdata_heretic2/video.c
-)
+add_subdirectory(quake2)