]> git.xonotic.org Git - xonotic/netradiant.git/blobdiff - radiant/CMakeLists.txt
Merge commit 'ca4a8002f895c3474b3a5087ff027c31dadc712f' into master-merge
[xonotic/netradiant.git] / radiant / CMakeLists.txt
index 3537a7ddc6ed326643ab2b3f5623c7a2d2380cc6..f93b00cf1329a8662fb132c1cd897372a38808a9 100644 (file)
@@ -36,7 +36,6 @@ set(RADIANTLIST
     filetypes.cpp filetypes.h
     filters.cpp filters.h
     findtexturedialog.cpp findtexturedialog.h
-    glwidget.cpp glwidget.h
     grid.cpp grid.h
     groupdialog.cpp groupdialog.h
     gtkdlgs.cpp gtkdlgs.h
@@ -124,6 +123,7 @@ target_link_libraries(${RADIANT_BASENAME}
     splines
     stream
     string
+    transformpath
     uilib
     xmllib
 )
@@ -146,8 +146,11 @@ endif ()
 #   warning: allocated section `.dynstr' not in segment
 # and produce an unusable binary, better not strip when using this hack.
 #
-# This hack is only wanted when NetRadiant is not installed system-wide.
-if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux"    AND NOT FHS_INSTALL)
+# This hack is only wanted for release build and
+# when NetRadiant is not installed system-wide.
+if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux"
+    AND "${CMAKE_BUILD_TYPE}" STREQUAL "Release"
+    AND NOT FHS_INSTALL)
     target_link_libraries(${RADIANT_BASENAME} -no-pie)
 endif()